SMART VIEW TRAINING GUIDE

C-BIG BUDGET INPUT

Office of Academic Planning & Budget
Updated December 2017
Contents

Smart View Training Guide ...................................................................................................................... 4
Smart View Overview ................................................................................................................................. 4
Installing Smart View ................................................................................................................................. 4
Setting Up Smart View Connection .......................................................................................................... 5
Connecting to Smart View .......................................................................................................................... 9
Setting Smart View User Options ............................................................................................................ 10
METHOD 1: Use Smart View to Pull Reports & Input Forms ................................................................... 12
METHOD 2: Reports and Input Forms through the Task List .................................................................... 15
Selecting your Entity and Fund ................................................................................................................... 16
Inputting and Submitting Budget Data .................................................................................................... 17
Adding Cell Comments ............................................................................................................................... 18
Adding Supporting Details .......................................................................................................................... 20
Adjust .......................................................................................................................................................... 22
Copying and Pasting ................................................................................................................................. 23
Applying Excel Formulas ............................................................................................................................ 23
Running Calculations ................................................................................................................................. 24
Data Validation ........................................................................................................................................... 25
  Deficit Budget Check .............................................................................................................................. 25
  Spread Check .......................................................................................................................................... 26
Approval Process ......................................................................................................................................... 26
Logging Off Smart View ........................................................................................................................... 27
Troubleshooting ........................................................................................................................................ 27
Smart View Training Guide

This training guide has been created to enable users to input their budget into C-BIG through the Smart View add-in. If any questions come up during your review of the information, please feel free to contact APB’s Hyperion Planning Analyst, Cathy Son, at cson@ponet.ucla.edu or x53833.

Smart View Overview

- Microsoft Office add-in for Oracle Hyperion Planning applications
- Allows users to input data through templates created for C-BIG
- Provides ad-hoc query capability to users in a familiar Excel environment
- Allows users to dynamically access the live data and develop their own queries
- Allows users to pull CBIG reports to manipulate in Excel

Installing Smart View

To begin, first install Smart View (with the help of your IT team, if needed).

1. To download, go to the APB C-BIG webpage and click the Download Smart View! link.
2. Download and install - be sure to right-click the .exe file and select Run as Administrator when installing.
3. Open Excel and verify that the Smart View tab is there.

    If there are other Excel Add-ins installed, you may need to disable them for Smart View to run properly (i.e. Acrobat PDFMaker Office COM Addin). Go to File > Options > Add-Ins > Excel Add-ins > Go... and uncheck add-ins you would like to disable (see image below).

    If Smart View is installed, but does not appear in Excel, make sure Oracle Smart View for Office is checked under both Excel Add-ins and COM Add-ins.
Setting Up Smart View Connection

1. After the installation of Smart View is complete, launch Microsoft Excel.
2. Select **Smart View** from the menu.
3. In the Smart View Ribbon, select **Options**:

4. Within the Options window, select **Advanced**.
5. In the **Shared Connections URL** section, copy the entire URL below and paste into the box:

   http://cbig.ais.ucla.edu:19000/workspace/SmartViewProviders
6. Click OK.

If you receive the following message when trying to save your Options, please create a log file by following the steps below:

7. In Options > Advanced, check Route Messages to File option and click on the ellipses icon to search for a file location:
9. Name your document “SmartViewLog.log” and select Open.
10. Uncheck the Route Messages to File option and click OK > Save as Default Options:
Connecting to Smart View

1. Click on the **Smart View** Ribbon.
2. Click on **Panel**.
3. In the Smart View panel, click on Shared Connections.

4. Enter your User Name and Password and click Connect:

5. Under Shared Connections, click on the dropdown that says "Select Server to proceed" and click Oracle Hyperion Planning, Fusion Edition:

Setting Smart View User Options

1. From the Excel ribbon, click the Smart View tab.
2. From the **Smart View** tab, click the **Options** icon:

3. Select **Data Options** and deselect all suppression options.
4. Change the **#NoData/Missing Label** to a dash, blank, or 0 (zero):

5. In the Options, select **Formatting** and select the **Adjust Column Width** option.
6. Once the Smart View Options have been set, click the drop down arrow next to the OK button.
7. Click Save as Default Options:

METHOD 1: Use Smart View to Pull Reports & Input Forms

There are usually two different ways to get to the same thing in Smart View. This is the first method which allows the user to pull everything into Smart View.

To view the Org/Dept Fund Check Report (or any other report),

1. Under Shared Connections, click on the dropdown that says "Select Server to proceed" and click Reporting and Analysis Framework
2. Follow the path below to get to 15 Bud Input – Org & Fund Check and double-click the report:

3. Enter your organization or department in the format “org_####” or “dpt_####” and click OK to preview the report.
4. Then click Finish to pull the report into Excel.

For more information about opening reports in Smart View, see the Formatted Reports via Smart View Training Manual (found on the C-BIG webpage).
To pull the budget input forms,

5. Under Shared Connections, click on the dropdown that says "Select Server to proceed" and click **Oracle Hyperion Planning, Fusion Edition**: 

![Oracle Hyperion Planning, Fusion Edition dropdown]

6. Follow the path below to open the Beginning Budget Form and Budget Seasonality Forms (quarterly or monthly – choose one):

![Smart View with Budget Forms]

7. Double click to open a form:
**Build Beginning Budget Form:**

Note: Historical actual and budget numbers will show on this form – this form is blank for the purpose of not displaying any department’s numbers.
Budget Seasonality Form (Quarterly or Monthly):

Note: Historical actual and budget numbers will show on this form – this form is blank for the purpose of not displaying any department’s numbers

Use a new sheet to open multiple reports/forms in one Excel workbook.

METHOD 2: Reports and Input Forms through the Task List

The Task List is the second method to access reports and input forms. It opens the reports through the web application.

1. Once connected to Oracle Hyperion Planning, Fusion Edition, drill into cbig.ais.ucla.edu > UCLA > Task Lists > FYXX Budget Input Process and double click:
2. The Task List steps include the input forms and the approval process. Double-click on a task to begin:

The selected task will open. If the task is to view a report, the C-BIG webpage will appear and you will need to log into the web to view the report.

If the selected task is to enter data in a form, the form will appear in the current Excel sheet.

Selecting your Entity and Fund

There are two drop-down menus on the input forms you have opened in Excel. The left drop-down menu allows you to select your department, and the right drop-down menu allows you to select your fund. After changing your selection, you must click the Refresh button to reflect the changes.

To change your department,

1. Select a department from the left drop-down menu and click Refresh:
To change your fund,

2. Select a fund from the right drop-down menu and click **Refresh**.

To use the search feature,

1. Click in the department or fund drop-down menu.
2. Type one or more characters (alphanumeric) of the department or fund name for which you are searching.
3. Select from the list that appears and then be sure to click **Refresh**.

---

**Inputting and Submitting Budget Data**

The cells with a grey background color represent read-only cells, while those with a light yellow background color represent input cells. After inputting data, the cell color will change to dark yellow, indicating that data has been changed but not yet submitted/saved to the database.

To submit/save your changes,

1. Click on **Submit Data** from the Planning ribbon:
2. If you get an error or the data will not submit (data disappears), please click **Refresh** and try again. If you are still having problems submitting data, please reach out to Cathy Son (cson@pomet.ucla.edu).

If, instead of saving your data, you would like to delete your unsaved changes:

3. Click on **Refresh** from the Planning ribbon:

4. At the following prompt, click on the **OK** button to confirm the Refresh command:

![Oracle Hyperion Smart View for Office, Fusion Edition](image)

Adding Cell Comments

To add Cell Comments,

1. Select a single cell or a range of contiguous cells.
2. Click on **Cell Actions > Comments** from the Planning ribbon:
3. Once the Comments window appears, click the + icon:

4. Enter comments (up to 2000 characters per each cell), then click Save then Close.
5. The cell will have a blue border, indicating that cell comments are present.

Adding Supporting Details
Supporting details are used to provide more detail behind a number. To add Supporting Details,

1. Select a single cell or a row of contiguous cells.
2. Click on Cell Actions > Supporting Details from the Planning ribbon:
3. Select the **Add Child** button.

![Supporting Details](image)

4. Type a description over the default “Untitled”, select an operator, and enter an amount.

![Line Items](image)

5. To add line items, select the **Add Sibling** button.
6. Type in a description, an operator, an amount for the additional rows and click on the **Submit** button when done.

The total amount will display on your form, and the cell background color will appear in aqua blue, indicating that there are Supporting Details.

| Perm Approp | 15500 | 0 | 0 | 0 |
| Temp Approp | 0 | 0 | 0 | 0 |
| **Total Revenue** | 15500 | 0 | 0 | 0 |
| Faculty Ladder | 0 | 0 | 0 | 0 |
| Faculty Temporary | 0 | 0 | 0 | 0 |
| Academic Apprentice | 0 | 0 | 0 | 0 |

To delete Supporting Details, simply go to **Cell Actions > Supporting Details > Delete** or **Delete All**.

**Adjust**

One cell or a range of cells can be adjusted by value or fixed percentage. To use the adjust function, highlight the cells you would like to change in a form, and in the Planning tab of Excel, go to **Adjust > Adjust**.

Select an adjustment option, enter the value or percentage, and then click **Adjust Data**.
Copying and Pasting

To copy and paste data from other Excel sheets, use Excel features (e.g. Ctrl c/x/v, dragging cell content, etc.). If the cells that you are copying are protected, you may be prompted to first unprotect the sheet. Click the Review tab > Unprotect Sheet before copying.

Applying Excel Formulas

The ability to apply Excel formulas to manipulate and analyze data is available. When applying Excel formulas, keep the following in mind:

- You can create formulas inside or outside the data form’s grid
- You cannot create formulas on read-only cells or on cells that have Supporting Details
- Formulas are preserved upon saving or refreshing your data
- You must save workbook as an Excel file
- A separate sheet must exist for each department and fund combination containing formulas
Running Calculations

Calculations, or business rules, are available for the forms in Smart View. There are *three rules* available from the Beginning Budget Form and Budget Seasonality Form.

To access the business rules,

1. Right-click on a row within the form and select a calculation from the Smart View menu. This can also be accessed by selecting Calculate > Rules on Form from the Planning ribbon.

**Beginning Budget Form:**

The business rules for the Build Beginning Budget Form will populate expense rows on the form. Therefore, you can right-click ANY of the rows (e.g. Faculty Ladder) and select a calculation to run for the entire form:

![Beginning Budget Form Image]

**Budget Seasonality Form:**

Business rules available for the Budget Seasonality Quarterly/Monthly Form are run for selected rows. Therefore, it is important that you right-click on the specific row you would like to alter.

To apply the calculation to multiple rows, right-click on the appropriate subtotal/parent row, then select the calculation (e.g. Selecting Total Salaries & Wages would apply the calculation to Faculty Ladder, Faculty Temporary, Academic Apprentice, Academic Other, Career Staff, and Non-Career Staff rows).
The rule will run and your beginning budget will be spread to the quarters/months (depending on what form you are using).

Data Validation

Data validation has been built in to the Beginning Budget Form and Budget Seasonality Quarterly/Monthly Form. There are two types of data validation: Deficit Budget Check and Spread Check.

Deficit Budget Check

If you enter a budget that results in a deficit at the Ending Balance row, Total or YearTotal columns, the cell will be highlighted in yellow. You may also notice a Data Validation Message, stating, “Please resolve the deficit budget prior to submitting” when the cell is highlighted. You must correct the deficit budget; however, the system will not prevent you from submitting deficit budgets for approval.
Spread Check
The Budget Seasonality Form will also check for To-Be-Spread amounts for each input row. If the To-Be-Spread amount is greater than 1 or less than -1 on a data input cell, the cell will be highlighted in yellow and a Data Validation message stating, “Please adjust your spread to match the annual budget” will appear. All To-Be-Spread issues must be resolved prior to submitting your budget.

Approval Process
The Approval process will NOT take place in C-BIG for the 2018-19 Budget Year (same as 2017-18). C-BIG users will be locked out of the system by the budget submission deadline: Friday, March 4, 2017.
Logging Off Smart View

To log off,

1. From the Smart View Panel, click on the down arrow next to the Home icon.

![Smart View Panel](image)

2. Select Disconnect All.


Troubleshooting

In the case that an error message appears while inputting budget, or your data cannot be submitted, please ensure that you have installed the latest version of Smart View. The latest version can always be found on the APB C-BIG webpage under the Download Smart View section.

In addition, many errors result from incorrectly installing Smart View. When installing, please remember to right-click the installation file and select “Run as Administrator”. Please uninstall a prior version (if found in the Remove Programs section of the Control Panel – sometimes it is not, depending on the version) before installing a new Smart View version.

Do not hesitate to contact the Hyperion Planning Analyst, Cathy Son (cson@ponet.ucla.edu), if assistance is needed.